Azure Cloud - Connectivity Issues

Incident Report for TEAM IM

Resolved

Microsoft Azure Front Door (AFD) service disruption can be considered as resolved. Microsoft informed vendors around midnight that service is restored and issue is mitigated. Based on M-Files own checks, M-Files service parts are working normally. Mitigation was mainly done by the Microsoft. They were forced to recovery required reloading configurations across a large number of nodes and rebalancing traffic. Mitigation took time because of the phased recovery which was necessary to stabilize the system while restoring scale and ensuring no recurrence of the issue. More information and RCA in: https://azure.status.microsoft/en-us/status/history/

Shared from the M-Files Cloud Support Team at 06:47 CT:
Due to an incident related to Microsoft Azure Front Door service disruption some of our M-Files Cloud vault customers may have experienced issues with accessing and using the service between 15:45 UTC on 29 October 2025 and 00:05 UTC on 30 October 2025.
The recovery actions performed by Microsoft restored the Azure Front Door service, resulting also in restoration of the affected M-Files Cloud services. That resolved the incident and the M-Files Cloud services are back to normal operation.
We sincerely apologize for the inconvenience this incident may have caused and appreciate your patience throughout this period.
More information from MS Azure status pages: Azure status history | Microsoft Azure Tracking ID: YKYN-BWZ

We have closed the incident on TEAM’s Status Page as well: https://status.teamim.com/.
Posted Oct 30, 2025 - 07:00 CST

Monitoring

Microsoft is reporting their AFD service is now operating above 98% availability. While the majority of customers and services are mitigated or seeing strong improvement across affected regions, they are continuing to work on tail-end recovery for remaining impacted customers and services. Microsoft has revised their mitigation time and are currently tracking toward full mitigation by 00:40 UTC on 30 October 2025, though they will communicate if mitigation is achieved sooner. M-Files is continuing to work on full recovery of their services.

Updates are available at https://support.m-files.com/disruption?uuid=5bcb47c6-5e41-4f37-a84f-4da702bbec88 and https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 17:56 CST

Identified

Microsoft initiated the deployment of their ‘last known good’ configuration, which has now successfully been completed. They are currently recovering nodes and routing traffic through healthy nodes, and as they make progress in this workstream, customers will continue to see improvement.

More M-Files Cloud / M-Files Manage customers are reporting they are no longer experiencing problems while others may still be encountering delays or temporary unavailability.

Updates are available at https://support.m-files.com/disruption?uuid=5bcb47c6-5e41-4f37-a84f-4da702bbec88 and https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 15:17 CST

Update

Microsoft initiated the deployment of their ‘last known good’ configuration, which has now successfully been completed. They are currently recovering nodes and routing traffic through healthy nodes, and as they make progress in this workstream, customers will continue to see improvement.

More M-Files Cloud / M-Files Manage customers are reporting they are no longer experiencing problems while others may still be encountering delays or temporary unavailability.

Updates are available at https://support.m-files.com/disruption?uuid=5bcb47c6-5e41-4f37-a84f-4da702bbec88 and https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 15:06 CST

Update

We’re seeing signs of recovery as Microsoft continues working to resolve the DNS configuration issue on their end. Some M-Files Cloud / M-Files Manage customers are no longer experiencing problems while others may still encounter delays or temporary unavailability.

According to Microsoft, the full recovery process on their side may take up to four hours - they are planning to finish by 23:20 UTC on 29 October 2025.

Updates are available at https://support.m-files.com/disruption?uuid=5bcb47c6-5e41-4f37-a84f-4da702bbec88 and https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 13:57 CST

Update

Microsoft continues to revert changes caused by a faulty DNS configuration, which has led to widespread service disruptions which include M-Files Cloud and M-Files Manage for some customers. Cloud and Manage customers may have experiences ranging from slow performance to outages of their sites to no impact. Updates are available at https://support.m-files.com/disruption?uuid=5bcb47c6-5e41-4f37-a84f-4da702bbec88 and https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 13:41 CST

Investigating

Microsoft is working to revert changes caused by a faulty DNS configuration, which has led to widespread service disruptions which include M-Files Cloud and M-Files Manage for some customers. Cloud and Manage customers may have experiences ranging from slow performance to outages of their sites to no impact. Updates are available at https://support.m-files.com/disruption?uuid=5bcb47c6-5e41-4f37-a84f-4da702bbec88 and https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 12:24 CST
This incident affected: M-Files Cloud / M-Files Manage.